aircraft

(1/1)

eddie:
  Legacy PT-SAB, this aircraft not work in fs2000?

Nick_KSTL:
All planes at the Project ERJ website need FS2002 or FS2004 to function.

Navigation

Up one level