FSnordic.net
Home Help Rules Login Register
Welcome, Guest. Please login or register.
16.12.17, 09:14

Login with username, password and session length
+  FSnordic.net Forums
|-+  Finnish Discussion / Lentosimulaattorit
| |-+  Verkkolentäminen (Moderators: Juha Kalli, Mikko Maliniemi, Janne Sinkkonen, Ilkka Portti, Mikko J Köykkä)
| | |-+  Ivap ei pysty tekemään multiplayersessiota - DirectX-ongelmaa?
:  

« previous thread next thread »
Pages: [1] Reply Print
Author Topic: Ivap ei pysty tekemään multiplayersessiota - DirectX-ongelmaa?  (Read 834 times)
Otto Nieminen
Offline Offline

Posts: 7596
Date Registered: 06.02.06

Ivap ei pysty tekemään multiplayersessiota - DirectX-ongelmaa?
« on: 21.06.11, 10:39 »

Terse.

Skeneongelmien rinnalle ilmeni viime viikolla myös vikaa Ivapin kanssa. Tästä on jo topikki IVAOn foorumeilla mutta sörkätään nyt tännekin josko joku osaisi paremmin auttaa täällä.

Ongelma on siis se, että Ivapia käynnistettäessä se ei saa tehtyä multiplayersessiota simun multiplayeriin jotta näkisin muun liikenteen. Käyttö siis onnistuu muuten, mutta muuta liikennettä ei näe.
Tarkalleen ottaen virheilmoitus on tällainen:
[ attachment removed / expired ]

Dxdiagista on katseltu mahdollisia vikoja, joita sieltä ei kuitenkaan löydy (sieltä ei edes näe tuota DirectPlayn tilaa, sillä uudemmassa DX11:ssä joka tässä win7ssa on ei tuota palikkaa enää ole). Varmaankin jokaista vinkkiä IVAOn foorumeilta on koitettu, kuten DX9n asennusta "silenttinä" korvatakseni puuttuvat/vioittuneet palikat joita simu ja Ivap tarvitsee, virustorjunnan ja palomuurin käytöstä poistamista tilapäisesti, yhteensopivuustilassa simun ajamista(+ adminina) ja Ivappia yritetty ajaa ilman että automaattinen MP-sessioon liittyminen on päällä. UPnPtkin otettu pois sekä itse wintoosasta että palomuurista, ei vaikutusta. Kaiken kivan kukkuraksi tuli vielä älyttyä palautuspisteiden olemassaolo hieman myöhään, miljoonaan kertaan asennettu DX9 ja ohjelmien uninstallerit olivat vääntäneet miljoonat palautuspisteensä wintoosaan kadottaen ne mahdolliset palautuspisteet n. viikon taakse joita olisin ehkä tarvinnut ja joilla olisin ratkaissut ongelman  Roll Eyes

Tässä vielä Ivapin network interfacen debugging-loki, jos siitä apua jollekin on;
Quote
IvAp Network Interface Debug Logfile - Created at 2011-06-19 12:49:46
---------------------------------------------------------------
[2011-06-19 12:49:46] IvAp v1.4.2.2411 / Windows v6.1.7601
[2011-06-19 12:49:46] Router: waiting for connections on port 6810
[2011-06-19 12:49:46] P2P: max rate 20 Hz
[2011-06-19 12:49:46] Multiplayer: hosting will be for FS2004
[2011-06-19 12:49:46] Registration of module 0: unknown
[2011-06-19 12:49:47] Registration change of module 0: user interface
[2011-06-19 12:49:47] Registration of module 1: unknown
[2011-06-19 12:49:47] ServerPing: EU5 has a ping of 64 and a load of 0.252000
[2011-06-19 12:49:47] ServerPing: EU1 has a ping of 65 and a load of 0.492000
[2011-06-19 12:49:47] ServerPing: EU11 has a ping of 66 and a load of 0.000000
[2011-06-19 12:49:47] ServerPing: EU12 has a ping of 70 and a load of 0.236000
[2011-06-19 12:49:47] ServerPing: EU2 has a ping of 70 and a load of 0.392000
[2011-06-19 12:49:47] ServerPing: EU7 has a ping of 71 and a load of 0.224000
[2011-06-19 12:49:47] ServerPing: EU9 has a ping of 71 and a load of 0.264000
[2011-06-19 12:49:47] ServerPing: EU8 has a ping of 72 and a load of 0.252000
[2011-06-19 12:49:47] ServerPing: EU6 has a ping of 75 and a load of 0.200000
[2011-06-19 12:49:47] ServerPing: EU3 has a ping of 107 and a load of 0.236000
[2011-06-19 12:49:47] ServerPing: AM2 has a ping of 180 and a load of 0.268000
[2011-06-19 12:49:47] ServerPing: AS1 has a ping of 328 and a load of 0.108000
[2011-06-19 12:49:47] ServerPing: best server is EU11
[2011-06-19 12:49:52] Registration change of module 1: flight simulator
[2011-06-19 12:49:52] Multiplayer: trying to host a multiplayer session
[2011-06-19 12:49:52] Multiplayer: hosting failed with error -2146073824 (HOST)
[2011-06-19 12:50:04] Unregister of module 0: User Interface
[2011-06-19 12:50:04] Unregister of module 1: Flight Simulator
[2011-06-19 12:50:13] Multiplayer: shutdown

Kiitoksia avusta  Cheesy
« Last Edit: 22.06.11, 10:27 by Otto Nieminen »
Mika Virolainen
Offline Offline

Posts: 3419
Date Registered: 18.12.01

Re: Ivap ei saa multiplayersessiota aikaiseksi - DirectX-ongelmaa?
« Reply #1 on: 22.06.11, 08:50 »

Apua tuskin voin antaa, mutta vaikuttaa samanlaiselta tilanteelta (FS9 + IvAp 1,3,8) kun simulaattori on kaatunut ja Ivap-kilkkeet suljettu (käynnistämättä konetta uudelleen), niin sama ilmoitus tulee kun palauttaa lennon (joka siis onnistuu autosave.DLL:n avulla) Ivapin käynnistyksessä (Ei muistaakseni tarvitse edes yrittää kirjautua serverille). Mikäli tietokoneen käynnistää uudelleen, palauttaa lennon ja käynnistää Ivapin, niin kaikki toimii normaaliin tapaan samalla kutsutunuksella.

T: Mika.
« Last Edit: 22.06.11, 09:00 by Mika Virolainen »

Otto Nieminen
Offline Offline

Posts: 7596
Date Registered: 06.02.06

Re: Ivap ei saa multiplayersessiota aikaiseksi - DirectX-ongelmaa?
« Reply #2 on: 22.06.11, 09:27 »

Joo tuo herja tulee siis jo Ivapin käynnistysvaiheessa, ennenkuin edes yrittää sisäänkirjausta.

Kaikki viittaisi siihen, että DirectXn kanssa on jotain häikkää  Huh
Mika Virolainen
Offline Offline

Posts: 3419
Date Registered: 18.12.01

Re: Ivap ei pysty tekemään multiplayersessiota - DirectX-ongelmaa?
« Reply #3 on: 22.06.11, 11:56 »

DirectX tuskin on syynä. Jotenkin liittyy kyllä DirectPlay:hin (villi veikkaus). Koitappa etsiä asennuslevyltä MULTIPLAYER.DLL ja korvaa se alkuperäisellä...?

Itselläni (FS9) MODULES -kansiossa. Aiemmin oli ongelmaa "autojoin in multiplayer session" -valinnan kanssa, ja muutaman vuoden liitin IvaP:n ilman tuota optiota aina manuaalisesti. Kerran sitten ajattelin josko moduulissa olisi ongelma, ja kopioin "puhtaasta" asennuksesta ko. tiedoston, ja tämän jälkeen on IvAp liittynyt sessioon automaattisesti.

Aika "hakuamuntaa", mutta myös MULTIPLAYER.DLL voi näköjään lakata toimimasta... Ainakin minulle näin kävi. Suoranaisestihan tämä ei edes liity ongelmaasi, mutta tätäkin kannattaa kokeilla?

T: Mika

Mika Virolainen
Offline Offline

Posts: 3419
Date Registered: 18.12.01

Re: Ivap ei pysty tekemään multiplayersessiota - DirectX-ongelmaa?
« Reply #4 on: 22.06.11, 12:15 »

Miten olet yrittänyt liittyä MULTIPLAYER -sessioon, jos Ivapista on "AUTOJOIN IN MULTIPLAYER" -optio ruksattu pois päältä?

Otto Nieminen
Offline Offline

Posts: 7596
Date Registered: 06.02.06

Re: Ivap ei pysty tekemään multiplayersessiota - DirectX-ongelmaa?
« Reply #5 on: 22.06.11, 12:16 »

Miten olet yrittänyt liittyä MULTIPLAYER -sessioon, jos Ivapista on "AUTOJOIN IN MULTIPLAYER" -optio ruksattu pois päältä?
Juu siis ongelmanahan on se, ettei Ivap edes saa tehtyä tuota sessiota. Joten jos yritän esim. mennä ylävalikon kautta multiplayeriin ja hakea ivapin tekemää sessiota johon liittyä niin sitä ei löydy. Jos tuollainen kuvaamasi tilanne olisi, niin sessionhan löytää kun ylävalikosta menet multiplayeriin ja haet sessiota osoitteella "localhost", löytyy sessio nimeltä Ivap johon liittyessäsi näet liikenteen.
Kuten sanoit, niin varmasti jotain tekemistä tuon DirectPlayn kanssa tällä ongelmalla on.

EDIT_ Niinja tuo multiplayer.dll:n korvaaminenkaan ei auttanut. Kovasti tekisi mieli poistaa DirectX jollain työkalulla ja asentaa uudelleen  Grin
« Last Edit: 22.06.11, 12:22 by Otto Nieminen »
Mika Virolainen
Offline Offline

Posts: 3419
Date Registered: 18.12.01

Re: Ivap ei pysty tekemään multiplayersessiota - DirectX-ongelmaa?
« Reply #6 on: 22.06.11, 12:30 »

No voi harmi thmbdn

Kaiken teit kuten minäkin, mutta jos IvAp ei usean eri "search" namiskan painamisen jälkeen tule allaolevaan valintaikkunaan, niin sitten en ymmärrä missä mättää... Embarrassed

Tosin itselläni on WinXp. Todella ikävää, että näin on käynyt!

Viimeisimpänä ehdottaisin IvaP:n poistamista, ja koneen uudelleenkäynnistämisen jälkeen asennusta eri levyosiolle / tai hakemistoon...

Toivottavasti saat pelittämään...

T: Mika

Otto Nieminen
Offline Offline

Posts: 7596
Date Registered: 06.02.06

Re: Ivap ei pysty tekemään multiplayersessiota - DirectX-ongelmaa?
« Reply #7 on: 25.06.11, 15:52 »

Jeps homma selvisi ainakin toistaiseksi, panin täytäntöön "korjaus"asennuksen wintoosalle tämän tutoriaalin mukaan. Parit softat kuten Chrome kadottivat juttunsa (mistä ei taitanut olla mainintaa tutoriaalissa, kiva yllätys  Roll Eyes) mutta niistä oli onneksi varmuuskopiot.
Pages: [1] Reply Print 
« previous thread next thread »
Jump to:  

1